upgrading somehow broke XeLaTeX?

Lenore Horner LenoreHorner at sbcglobal.net
Mon Sep 30 10:30:43 PDT 2013

I printed a physics test last week.  This week I can create a new pdf file but it says it may not be valid and Skim won't open it.  Over the weekend I, finally, upgraded from 10.6.8 to 10.8.5.  As a consequence I downloaded the new Xcode and installed the command line utilities and pointed everything in the right direction.  Then I reinstalled MacPorts from .dmg and the ran sudo port self update and then sudo port upgrade outdated.  All of which took time but apparently worked correctly.  However, I am having this problem with generating invalid pdf files now.  I've narrowed the error down to an include graphics which points to a .png file.  Everything is fine if I comment that line out.  The pdf file is corrupt (see error message below) if I leave that line in.  I haven't changed the drawing since last week.  I tried reading through the log file, but nothing jumped out at me.  

MacBook Air 
core 2 duo

/opt/local/libexec/texlive/texbin/xelatex --synctex=1 --interaction=nonstopmode
This is XeTeX, Version 3.1415926-2.5-0.9999.3 (TeX Live 2013/MacPorts 2013_2)
restricted \write18 enabled.
entering extended mode

Error 6 (driver return code) generating output;
file T02-moreForces.pdf may not be valid.


More information about the macports-users mailing list