upgrading somehow broke XeLaTeX?

Daniel J. Luke dluke at geeklair.net
Mon Sep 30 10:57:35 PDT 2013

On Sep 30, 2013, at 1:30 PM, Lenore Horner <LenoreHorner at sbcglobal.net> wrote:
> I printed a physics test last week.  This week I can create a new pdf file but it says it may not be valid and Skim won't open it.  Over the weekend I, finally, upgraded from 10.6.8 to 10.8.5.  As a consequence I downloaded the new Xcode and installed the command line utilities and pointed everything in the right direction.  Then I reinstalled MacPorts from .dmg and the ran sudo port self update and then sudo port upgrade outdated.  All of which took time but apparently worked correctly.

That's not the correct procedure for migrating to a new OS release, please see:


I would try following the Migration instructions as a first step.

> However, I am having this problem with generating invalid pdf files now.  I've narrowed the error down to an include graphics which points to a .png file.  Everything is fine if I comment that line out.  The pdf file is corrupt (see error message below) if I leave that line in.  I haven't changed the drawing since last week.  I tried reading through the log file, but nothing jumped out at me.  

Daniel J. Luke                                                                   
| *---------------- dluke at geeklair.net ----------------* |                          
| *-------------- http://www.geeklair.net -------------* |                          
|   Opinions expressed are mine and do not necessarily   |                          
|          reflect the opinions of my employer.          |                          

More information about the macports-users mailing list