Reason: Incompatible library version: libfontconfig.1.dylib requires version 8.0.0 or later, but libexpat.1.dylib provides version 7.0.0

Clemens Lang cal at
Mon Dec 1 07:18:55 PST 2014

Hi Geoffrey,

Please don't post to macports-tickets. It's a read-only list for mails generated by
our bug tracker at Use the bug tracker or macports-users instead.

> In a php script I call the ImageMagick convert command via a php exec command. I
> get the error printed in the title. Following a thread of the same title I did
> the following:
> otool -L /opt/local/lib/libfontconfig.1.dylib
> and got...
> /opt/local/lib/libfontconfig.1.dylib (compatibility version 10.0.0, current
> version 10.0.0)
> /opt/local/lib/libfreetype.6.dylib (compatibility version 18.0.0, current
> version 18.2.0)
> /opt/local/lib/libexpat.1.dylib (compatibility version 8.0.0, current version
> 8.0.0)
> /usr/lib/libSystem.B.dylib (compatibility version 1.0.0, current version
> 125.2.11)
> I'm running on localhost with Apache via xammp on a mac operating with snow
> leopard.
> Many thanks in advance for any assistence.

I'm betting you (or the environment that runs the failing command) has
DYLD_LIBRARY_PATH set, probably to /usr/lib. Unset that and it should start
working again.

See also

Clemens Lang

More information about the macports-users mailing list