smartd automated scanning failing

Bradley Giesbrecht pixilla at
Sat Dec 6 12:22:39 PST 2014

On Dec 6, 2014, at 1:42 AM, Ubence Quevedo <thatrat at> wrote:

>> What happens if you run smartd manually in debug mode and without forking:
>> sudo port unload smartmontools
>> sudo /opt/local/sbin/smartd -n -d -c /opt/local/etc/smartd.conf
>> When I ran manually without sudo smartd complained about not being able to write a state file to:
>> /opt/local/var/lib/smartmontools/smartd.Hitachi_HDS722020ALA330-JK1174YAK4MZ3W.ata.state
> When I ran the smartd like you did from the command line like the above, it seems to work properly:
> Ubences-Intel-iMac:etc uquevedo$ sudo /opt/local/sbin/smartd -n -d -c /opt/local/etc/smartd.conf
> smartd 6.2 2013-07-26 r3841 [x86_64-apple-darwin14.0.0] (local build)
> There is an entry on the Mac Ports Trac site for an upgrade to 6.3 here:
> I’m going to try compiling smartmontools from source and give that a try to see if I still run into the same issue and hope that the 6.3 update whenever it is released from Mac Ports will fix this problem.
> I’ll also likely post a bug report since there doesn’t seem to be one for this already.

I noticed smartd has a -n no-fork flag. I'm testing with this modified launchd script:
<?xml version='1.0' encoding='UTF-8'?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN"
"" >
<plist version='1.0'>

Bradley Giesbrecht (pixilla)

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 455 bytes
Desc: Message signed with OpenPGP using GPGMail
URL: <>

More information about the macports-users mailing list