Problem with Macports, homebrew, and ghostscript at at
Tue Feb 11 01:08:59 PST 2014

(I apologize if this message appears more than once; I haven't used the list in a long time, and I had some problem figuring out how I set it up the first time. I have tried a few times to post, but it has failed to appear...I think I was using the right address this time, though I also tried to post via gmane....)

Based on some bad internet advice I appear to have installed homebrew without realizing it is not compatible (so to speak) with macports, and so I installed ghostscript via homebrew, without realizing that I had already installed it via macports, and that it appears to have been already installed "natively"...

What I mean is:

If I "port installed" I can see
ghostscript @9.10_0
  ghostscript @9.10_2+x11 (active)

If I "brew list installed" I see
ghostscript: stable 9.07, HEAD
but actually it is not linked, and I get a message
Could not symlink file: /usr/local/Cellar/ghostscript/9.07/bin/wftopfa
Target /usr/local/bin/wftopfa already exists. You may need to delete it.

but if I just run gs straight from the terminal, I have
GPL Ghostscript 9.05 (2012-02-08)

I don't know how I created this mess...but am not sure what to do.

Should I delete ghostscript from homebrew? If I do will I destroy it from macports? Will I destroy the 9.05 version?
I know that I am using ghostscript with LyX and some other TeX programs...I will have to figure out how to make sure they will still function but I think they all look for gs in usr/local/bin...ack!
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the macports-users mailing list