Fwd: Problems linking static glib2.0

Jameson Merkow jmerkow at gmail.com
Tue Oct 7 10:23:03 PDT 2014

I've been using macports for a while. I've been using apple-gcc42 compiler,
but I recently switched to mp-gcc46, to use mpich-gcc46.  Now that I've
switched, Im running into link errors (attached) with the installed
glib2.0.  I am linking against the archive, not the dylib (this was working
with apple-gcc42). I've tried installing and reinstalling it a few times,
to no avail, perhaps I am missing a step?
I have the following glib installed:
glib2                          @2.42.0         devel/glib2

I have also tried glib2-devel version.

Any help debugging, or if Im missing something, would be greatly

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.macosforge.org/pipermail/macports-users/attachments/20141007/d07424ad/attachment.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: gliberror.log
Type: application/octet-stream
Size: 1697 bytes
Desc: not available
URL: <https://lists.macosforge.org/pipermail/macports-users/attachments/20141007/d07424ad/attachment.obj>

More information about the macports-users mailing list