Strange problems with launchd and macports toolchains/libraries

Brandon Allbery allbery.b at
Thu Oct 23 08:35:42 PDT 2014

On Thu, Oct 23, 2014 at 11:17 AM, Jameson Merkow <jmerkow at> wrote:

> This works perfectly on linux (automatic and cron) and on mac when I
> initiate the build manually, but when I added it to a launchd (or cronjob).
> I believe that the issue lies with the toolchain, when I run the script,
> the tool chain used is the one in /opt/local/, however when I run the
> script, it uses XCode's toolchain for some reason... It also not finding
> any of the mp libraries (i.e. glib).
> Any Idea why this might be? I've tried setting the path in the script, but
> this does not help. And Im out of ideas as to the cause.

The first thing to look at in such cases is to compare the output of `env`
from a shell and in the cron job. $PATH is far from the only thing that can
affect builds.

brandon s allbery kf8nh                               sine nomine associates
allbery.b at                                  ballbery at
unix, openafs, kerberos, infrastructure, xmonad
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the macports-users mailing list