Strange problems with launchd and macports toolchains/libraries

Jameson Merkow jmerkow at
Thu Oct 23 08:17:30 PDT 2014


I am working on setting up a build-bot on OS X 10.8.5, but I'm having some
issues when I use my scripts with launchd.

Our software downloads configures, and builds a few other packages using
cmake. One of these external projects is GTS, which, uses configure (as
opposed to cmake) to configure and build using make and gcc.
So to use the mp libraries and compilers we configure it specifying the
compiler that used by cmake, i.e. something like:
${${proj}_OUTPUT_DIR}/configure --prefix=${GTS_INSTALL_DIR}

These values are set to a mp compiler.

This works perfectly on linux (automatic and cron) and on mac when I
initiate the build manually, but when I added it to a launchd (or cronjob).

I believe that the issue lies with the toolchain, when I run the script,
the tool chain used is the one in /opt/local/, however when I run the
script, it uses XCode's toolchain for some reason... It also not finding
any of the mp libraries (i.e. glib).

Any Idea why this might be? I've tried setting the path in the script, but
this does not help. And Im out of ideas as to the cause.

I know this isn't specifically a macports issue, but since I am trying to
use the macports toolchain, I thought someone else might have run into

Thank you!!
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the macports-users mailing list