René J.V. Bertin
rjvbertin at gmail.com
Sun Oct 26 17:04:31 PDT 2014
On Monday October 27 2014 00:54:32 Marko Käning wrote:
> > Would it make sense to name this variant "debug" instead? It would be nice to avoid variants whose names begin with "no”.
I've started calling the variant +devel since that discussion. But AFAIC it doesn't need to be included in an official port ...
> there is a “debug” variant already available due to the kde portgroup...
> Why did you need to introduce a “nostrip” variant? Is that because of CMAKE_STRIP:FILEPATH?
The KDE +debug variant requires qt4-mac +debug, and that's a sort of frankenmonster I'd prefer to avoid. It's basically useless, most importantly because AFAIK it doesn't allow post-mortem debugging.
My variant builds with RelWithDebInfo (as opposed to Release used by normal MacPorts builds) and takes an extra step to prevent that debug info from being stripped. I've never been very good with names, so called it +nostrip.
More information about the macports-users