Cmake failed to build & GIMP Inkscape Gnumeric do not start

Enrico Pirani enrico.pirani at
Tue Apr 14 14:12:00 PDT 2015

Inviato da iPad

> Il giorno 14/apr/2015, alle ore 17:04, René J.V. Bertin <rjvbertin at> ha scritto:
> On Tuesday April 14 2015 16:37:06 Enrico Pirani wrote:
>>> You mean the X server ( or isn't started automatically when you start an X application?
>> X server is running ok (oddly Dia is opening correctly). Just the other
>> apps: zathura, gimp, inkscape, and KDE..)
> First off: KDE doesn't use X11 on OS X, at least not when you install it through MacPorts.
> If X apps fail to connect to a running X server something else is awry; they probably try to connect to the wrong $DISPLAY. That said, I've been seeing an issue on an OS X 10.6 VM where even from a terminal I couldn't connect to DISPLAY=:0.0 but DISPLAY=localhost:0.0
> worked perfectly fine. That must be something else though, because if you're trying to start X applications through LaunchServices (Finder, Dock, ...) your DISPLAY variable supposedly contains the path to a socket rather than a more traditional [host]:display.screen string.
I run application from terminal. Tried to clean-reinstall xorg and log-out. This happened after upgrading ports... Pity, even if I know there are precompiled version of some apps I prefer compiled version running under xfree.. 

More information about the macports-users mailing list