Error: Insufficient privileges to write to MacPorts install prefix.

Mihai Moldovan ionic at
Fri Aug 7 08:18:05 PDT 2015

On 07.08.2015 10:37 AM, Rainer Müller wrote:
> On 2015-08-07 07:03, Jim Mattingly wrote:
>> Getting the above-referenced error code when attempting command: port
>> install pspp, Have even tried sudo, although it is only a single-user
>> computer at home, then sudo scolds me and asks for a password I don’t
>> have. Downloaded Xcode from app store and macports, according to
>> macports guide, and env command worked just fine, but both install
>> and selfupdate commands tell me I don’t have the necessary privileges
>> to run them. Simply running commands on apple terminal with Xcode
>> open. Any ideas what to do? I’m perhaps a relatively advance user,
>> but not an IT pro, so perhaps there is something simple I’m
>> overlooking.
> You can't use sudo without setting a password for your user account.

That's the way better answer.

Also, make sure that your user account type is setup as "Administrator", not
"Standard" or "Guest" in System Preferences -> Users and Groups (it should be,
but please double-check.)

You can also set a password there.

After logging out and back in, sudo should magically work.

Don't go the other route "enabling" the root account via Directory Utility or
changing the sudoers file...


-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 884 bytes
Desc: OpenPGP digital signature
URL: <>

More information about the macports-users mailing list