Error: Insufficient privileges to write to MacPorts install prefix.

Jim Mattingly jem0716 at
Fri Aug 7 09:38:00 PDT 2015

The password thing worked. Already had a password, but thought sudo was
asking me for a sudo credential, which I didn't have (as Ludwig noted). It
was asking me for my iMac password! When I entered it, the port install
command worked immediately. Thanks for your help! Beers all around.

On Fri, Aug 7, 2015 at 10:18 AM, Mihai Moldovan <ionic at> wrote:

> On 07.08.2015 10:37 AM, Rainer Müller wrote:
> > On 2015-08-07 07:03, Jim Mattingly wrote:
> >> Getting the above-referenced error code when attempting command: port
> >> install pspp, Have even tried sudo, although it is only a single-user
> >> computer at home, then sudo scolds me and asks for a password I don’t
> >> have. Downloaded Xcode from app store and macports, according to
> >> macports guide, and env command worked just fine, but both install
> >> and selfupdate commands tell me I don’t have the necessary privileges
> >> to run them. Simply running commands on apple terminal with Xcode
> >> open. Any ideas what to do? I’m perhaps a relatively advance user,
> >> but not an IT pro, so perhaps there is something simple I’m
> >> overlooking.
> >
> > You can't use sudo without setting a password for your user account.
> >
> >
> That's the way better answer.
> Also, make sure that your user account type is setup as "Administrator",
> not
> "Standard" or "Guest" in System Preferences -> Users and Groups (it should
> be,
> but please double-check.)
> You can also set a password there.
> After logging out and back in, sudo should magically work.
> Don't go the other route "enabling" the root account via Directory Utility
> or
> changing the sudoers file...
> Mihai
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the macports-users mailing list