apple-gcc42 fails to build

Ryan Schmidt ryandesign at
Tue Aug 18 22:12:57 PDT 2015

On Aug 18, 2015, at 1:44 PM, Thomas Ruedas wrote:

> On 18/8/15 3:43 AM, Ryan Schmidt wrote:
>> I see from the above that you have cctools installed with the llvm33 variant,
>> which is the default on Leopard, but you could try using a newer version of
>> llvm with cctools, by running
>> sudo port install cctools +llvm36
>> or
>> sudo port install cctools +llvm35
>> or
>> sudo port install cctools +llvm34
> I tried all three, and even for the last variant I get
> --->  Computing dependencies for cctools
> --->  Dependencies to be installed: llvm-3.4 apple-gcc42
> at which point he begins to download and compile apple-gcc42 again. So the snake bites its tail.

Hmm. Ok, I do see that the llvm-3.4 portfile does blacklist gcc 4.2 build 5577 and older (in other words, the versions of gcc 4.2 in Xcode 3.1.4 and earlier), so you're right, that won't work here. However, I don't see that same blacklist in the llvm-3.5 and llvm-3.6 portfiles. Did you get the same error for the +llvm35 or +llvm36 variants, or a different error?

More information about the macports-users mailing list