ocaml 4.02.2 won't build on Snow Leopard

Peter Hancock hancock at fastmail.fm
Wed Jul 1 02:08:36 PDT 2015

On 01/07/2015 08:24, Ryan Schmidt wrote:
> On Jun 30, 2015, at 6:22 AM, Peter Hancock wrote:
>> Before I write a ticket, I wonder if anyone else has had problems in gettin ocaml at 4.02.2 to build.
>> This is on an early MacBook1,1, with OSX 10.6.8, Xcode 3.2.4.
>> The occasion of the error in the log file seems to be
>>   ld: absolute addressing (perhaps -mdynamic-no-pic) used in _caml_system__code_begin
>>   from i386.pic.o not allowed in slidable image.
>>   Use '-read_only_relocs suppress' to enable text relocs:
> That's a 32-bit Mac, right? Might be a 32-bit specific problem.

That's correct.

I tried to build ocaml myself from github, using a configure command that the INSTALL file
seems to recommend. make world and make bootstrap worked, but make opt failed with a ld error
about illegal text relocation, that looks similar (not exactly) to the macports error.

Browsing around the ocaml bug tracking site, I notice that one or two people with lots more clue than me
are struggling with this (acknowledged) issue.

Maybe it'll get fixed; maybe they'll just explicitly drop support for 32 bits.
Should I go ahead and raise a macports ticket?

For me ocaml is a build dependency for the latest versions of unison and hevea. I still have
unison 2.48.3 on my prehistoric macbook, so maybe I can survive.  hevea doesn't matter.

More information about the macports-users mailing list