Rebuild old version of port?

Ryan Schmidt ryandesign at
Thu Oct 8 05:57:01 PDT 2015

On Oct 7, 2015, at 9:53 AM, Adam Dershowitz wrote:

> Is there a way that I can rebuild and reactivate an older version of a  port?  I know about this link:  but the problem I have is a little bit different.
> I have the old versions still on my computer, including the source (these were ports that build from source), and they are for a port that is not hosted on macports.  
> The problem is that one of the dependents changed, so if I just activate the old version it fails.  So, what I want is essentially to “activate from source” or “rebuild @version)” since I already have the source and the port for the old version.  
> I can just activate the old version because there is the issue of a bad link, so it needs to be rebuilt.  
> I tried: 
> sudo port install myport @myoldversion but it tried to rebuild the new version, which is not what I want.  
> I also tried just giving the source flag:
> sudo port activate -s myport @myoldversion but then it just activated the old version.  
> I actually had no intention of yet upgrading this port, but when I upgraded one of the dependents , macports found that the port was now broken, and proceeded to download the new version of the port before rebuilding.  But, that new version is actually broken (for a completely unrelated reason).  So, now I can’t use the new version of the port, and I want to go back to the old version, but I can just activate it, because of the dependent issue.  So, I want to just have macports rebuild the old version from source.  

I don't know what to tell you. I don't completely understand your issue. InstallingOlderPort explains how to install an older version of a port. "sudo port install" does not support an "@version" modifier.

Maybe it would help if you told us what version of what port you're trying to build, and, since you said it's not hosted on MacPorts, where it's hosted, or where you got it.

More information about the macports-users mailing list