p5.16-libapreq2 won't reinstall after migration to El Capitan: configuring mod_perl2 +perl5_16 failed

Murray Eisenberg murrayeisenberg at gmail.com
Wed Oct 28 12:28:39 PDT 2015

OK, I'm trying to install p5.16-libapreq. Here's what I tried:

(1) deactivated all versions of perl5 except perl5.16 @5.16.3_1 

(2) deactivate of mod_perl2 @2.0.8_2+perl5_20; uninstall mod_perl2 @2.0.8_2+perl5_16+perl5_20

(3) install mod_perl2 @2.0.8_2+perl5_16, which gives configure failure:

:notice:configure --->  Configuring mod_perl2
:debug:configure Using compiler 'Xcode Clang'
:debug:configure Executing org.macports.configure (mod_perl2)
:info:configure Reading Makefile.PL args from @ARGV
:info:configure    MP_APXS = /opt/local/apache2/bin/apxs
:info:configure no conflicting prior mod_perl version found - good.
:info:configure [  error] Unable to determine server version, aborting.
:info:configure [  error] Invalid MP_APXS specified?
:info:configure Command failed: /opt/local/bin/perl5.16 Makefile.PL MP_APXS=/opt/local/apache2/bin/apxs 

Now what?

On Tue, 27 Oct 2015 23:27:27 +0100, Mojca Miklavec <mojca at macports.org>
> After migrating macports from Yosemite to El Capitan, installing p5.16-libapreq2 failed during build its all-too-tamiliar error:
>  Can't locate ModPerl/MM.pm in @INC
> Following a recommendation when the same thing happened under Yosemite, with the reinstalled macports under El Capitan I did follow the same procedure:
>  * install perl5 with a variant that corresponds to the perl version you want to use
>    I think I got this right; I have:
>        perl5 @5.16.3_0+perl5_16
>        perl5 @5.16.3_0+perl5_20 (active)
>  * forcibly rebuild mod_perl2 from source (i.e. "sudo port -ns upgrade --force mod_perl2") or if you have not yet installed mod_perl2, install it from source (i.e. "sudo port -s install mod_perl2")
>    I did the force rebuild of mod_perl2.
>  * install the p5-libapreq2 support for the perl version you want to use
>    I tried "sudo port install p5.16-libapreq2", which failed.
> Also, I note that there no longer seems to be any p5.20-libapreq2 port available.
> How fix??

If you want to keep using perl5perl +perl5_20, then you need to
install mod_perl2 +perl5_20 and p5.20-libapreq2. I have no clue why
p5.20-libapreq is missing and thin could be fixed.

If you want to switch to 5.16, you need to install perl5 +perl5_16,
then mod_perl2 +perl5_16 and finally p5.16-libapreq2.
Murray Eisenberg		murrayeisenberg at gmail.com
503 King Farm Blvd #101		Home (240)-246-7240
Rockville, MD 20850-6667	Mobile (413)-427-5334

More information about the macports-users mailing list