Lynx color support broken by update

David Vergnaud dvergnaud at
Thu Sep 3 08:05:28 PDT 2015

Hello everyone,  
I've just run a "port upgrade outdated" on my Yosemite 10.10.5 iMac. Quite honestly, I can't remember when was the last time I did, but I think it can't have been that long since I got the Mac only a few months ago and that's got to be when I first installed MacPorts. Still, it did some updates, amongst which lynx, taking it to version 2.8.8rel.2, which is weird because it says the version is from March 09 2014. Anyway, lynx used to be working fine with the previous version (looking at another Mac that hasn't been updated, it was probably 2.8.7rel.1), now however it seems the color/style support has been broken: pages are displayed with only white text on black background, no highlighting of any kind, no active link. I've tried to enable the "Show cursor" option in the in-app Options but that didn't have any effect. I've tried specifying the lss file (/opt/local/etc/lynx.lss) on the command line but that didn't do anything either. 
Also, looking at the release notes (, there seems to be an option -default-colors available in 2.8.8, and I was thinking this might have an effect, but it doesn't seem to work either, the option is not recognized :-(. 
So now I'm annoyed that lynx got broken and surprised that the situation doesn't seem consistent. I'm wondering what my options are and if someone has answers to the following questions: - is there a way to fix my currently installed version? - is it possible to revert to the previous version of lynx using macports? - if ever I get it to work again, does anyone know of a way to toggle between colored/non-colored mode within lynx? Some sites are displayed using e.g. dark blue which isn't really readable on a dark background. 
Thanks a lot for your help!
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the macports-users mailing list