port [m]dmg and PackageMaker

René J.V. Bertin rjvbertin at gmail.com
Tue Apr 12 08:41:58 PDT 2016

On Tuesday April 12 2016 14:43:22 Jeremy Lavergne wrote:
> PackageMaker should be available on the Apple developer site.

Are you sure?


returns 0 hits for me

and the latest "Auxiliary Tools" that still contain PackageMaker are from July 2012.

That version doesn't crash, though, and appears to work. However:

%> port -nvok dmg `port-active-variants -echo zlib` configure.optflags="-O3 -march=native -g"
--->  Fetching archive for zlib
--->  Unpacking txz archive for zlib 1.2.8_1+cloudflare+universal
--->  Extracting zlib-1.2.8_1+cloudflare+universal.darwin_13.i386-x86_64.txz
--->  Archive zlib-1.2.8_1+cloudflare+universal.darwin_13.i386-x86_64.txz unpacked
--->  Creating pkg for zlib version 0_1.2.8_1 at /opt/local/var/macports/build/_opt_local_site-ports_archivers_zlib/zlib/work/zlib-1.2.8_1.pkg
productbuild: Wrote product to /opt/local/var/macports/build/_opt_local_site-ports_archivers_zlib/zlib/work/zlib-1.2.8_1.pkg
--->  Creating disk image for zlib-1.2.8
Error: Failed to dmg zlib: error copying "/opt/local/var/macports/build/_opt_local_site-ports_archivers_zlib/zlib/work/zlib-1.2.8.pkg": no such file or directory
Error: See /opt/local/var/macports/logs/_opt_local_site-ports_archivers_zlib/zlib/main.log for details.
Error: Follow http://guide.macports.org/#project.tickets to report a bug.
Error: Processing of port zlib failed

IOW, it seems that the dmg command doesn't take the revision into account?
(port dmg bzip2 works fine for me)

Something else: I have a recollection that either of the pkg, mpkg, dmg or mdmg commands started a build-from source, the last time I tried, quite a while ago. The current implementation didn't for zlib and bzip2, but is now building xz after I tried `port mdmg xz+universal`. Yet I that's how I have xz installed?!


More information about the macports-users mailing list