port [m]dmg and PackageMaker

Ryan Schmidt ryandesign at macports.org
Tue Apr 12 10:47:33 PDT 2016

On Apr 12, 2016, at 10:41 AM, René J.V. Bertin wrote:

> On Tuesday April 12 2016 14:43:22 Jeremy Lavergne wrote:
>> PackageMaker should be available on the Apple developer site.
> Are you sure?
> https://developer.apple.com/downloads/?name=packagemaker
> returns 0 hits for me
> and the latest "Auxiliary Tools" that still contain PackageMaker are from July 2012.
> That version doesn't crash, though, and appears to work. However:
> %> port -nvok dmg `port-active-variants -echo zlib` configure.optflags="-O3 -march=native -g"
> --->  Fetching archive for zlib
> --->  Unpacking txz archive for zlib 1.2.8_1+cloudflare+universal
> --->  Extracting zlib-1.2.8_1+cloudflare+universal.darwin_13.i386-x86_64.txz
> snip
> --->  Archive zlib-1.2.8_1+cloudflare+universal.darwin_13.i386-x86_64.txz unpacked
> --->  Creating pkg for zlib version 0_1.2.8_1 at /opt/local/var/macports/build/_opt_local_site-ports_archivers_zlib/zlib/work/zlib-1.2.8_1.pkg
> productbuild: Wrote product to /opt/local/var/macports/build/_opt_local_site-ports_archivers_zlib/zlib/work/zlib-1.2.8_1.pkg
> --->  Creating disk image for zlib-1.2.8
> Error: Failed to dmg zlib: error copying "/opt/local/var/macports/build/_opt_local_site-ports_archivers_zlib/zlib/work/zlib-1.2.8.pkg": no such file or directory
> Error: See /opt/local/var/macports/logs/_opt_local_site-ports_archivers_zlib/zlib/main.log for details.
> Error: Follow http://guide.macports.org/#project.tickets to report a bug.
> Error: Processing of port zlib failed
> IOW, it seems that the dmg command doesn't take the revision into account?
> (port dmg bzip2 works fine for me)
> Something else: I have a recollection that either of the pkg, mpkg, dmg or mdmg commands started a build-from source, the last time I tried, quite a while ago. The current implementation didn't for zlib and bzip2, but is now building xz after I tried `port mdmg xz+universal`. Yet I that's how I have xz installed?!

"port dmg zlib" works fine for me on El Capitan. I do not have PackageMaker installed; this causes MacPorts to take a different path which creates non-flat (old pre-Leopard-style) packages. 

jmr created the packages for MacPorts 2.3.4; he must've had PackageMaker installed, because he created and uploaded flat packages.

I installed PackageMaker from the Auxiliary Tools for Xcode - Late July 2012, and then, as you said, "port pkg" works and successfully creates a flat package.

You are correct, we should probably add code to use pkgbuild instead of PackageMaker on newer OS X versions. The ticket for that is:


You are correct, there appears to be a bug where "port dmg" assumes that the package name does not have a revision number, but "port pkg" adds a revision number to the package name if the revision is not zero. I don't see a ticket filed for that yet; please file one if you have time.

More information about the macports-users mailing list