texlive-bibtex-extra installation breaks poppler-qt4-mac

Thomas Ruedas trg818 at gmail.com
Tue Apr 19 15:56:20 PDT 2016

a few days ago I installed texlive-bibtex-extra, and at some stage of 
the installation, there was this message:
--->  Scanning binaries for linking errors
--->  Found 3 broken file(s), matching files to ports
--->  Found 2 broken port(s), determining rebuild order
--->  Rebuilding in order
      ImageMagick @6.9.3-4 +x11
      poppler-qt4-mac @0.41.0
The installation proceeded automatically with rebuilding ImageMagick, 
which apparently worked, and the with rebuilding poppler-qt4-mac, which 
--->  Extracting poppler-qt4-mac
Error: org.macports.extract for port poppler-qt4-mac returned: command 
execution failed
Please see the log file for port poppler-qt4-mac for details:
Error: Unable to upgrade port: 1
Error rebuilding poppler-qt4-mac
     while executing
"error "Error rebuilding $portname""
     (procedure "revupgrade_scanandrebuild" line 395)
     invoked from within
"revupgrade_scanandrebuild broken_port_counts $opts"
     (procedure "macports::revupgrade" line 5)
     invoked from within
"macports::revupgrade $opts"
     (procedure "action_revupgrade" line 2)
     invoked from within
"action_revupgrade $action $portlist $opts"
     (procedure "action_target" line 96)
     invoked from within
"$action_proc $action $portlist [array get global_options]"
     (procedure "process_cmd" line 103)
     invoked from within
"process_cmd $remaining_args"
     invoked from within
"if { [llength $remaining_args] > 0 } {

     # If there are remaining arguments, process those as a command
     set exit_status [process_cmd $remaining..."
     (file "/opt/local/bin/port" line 5268)

I then cleaned the poppler-qt4-mac installation and tried to reinstall 
it, but it still doesn't work, and the logfile doesn't really help 
either; at least it doesn't show an actual error message, as it usually 
does in such cases. So I'm stuck. Any ideas?
I should mention that, as far as I can tell, both ImageMagick and 
poppler-qt4-mac worked before I installed the texlive-bibtex-extra package.

More information about the macports-users mailing list