iso-codes_3.43 not found but seems to be the default

Ryan Schmidt ryandesign at
Wed Apr 20 12:02:22 PDT 2016

On Apr 20, 2016, at 13:40, Patty J Bragger-Wilkinson wrote:
> Hi everyone,
> I’m new to macports, and maybe I’m missing something silly, but I’ve searched a bunch and can’t find an answer to my problem..
> I’m trying to install meld, which has a dependency on iso-codes
> port is constantly trying to install version 3.43, even though this version is nowhere to be found in any of the mirrors.  I see many newer versions available, but when I try to specify a newer version to install, it keeps looking for the older 3.43
> I’m running MacOS X El Capitan
> MacPorts 2.3.4
> Here’s the command I’m trying:
> $ sudo port install iso-codes @3.67
> --->  Computing dependencies for iso-codes
> --->  Fetching distfiles for iso-codes
> --->  Attempting to fetch iso-codes_3.43.orig.tar.xz from
> --->  Attempting to fetch iso-codes_3.43.orig.tar.xz from
> --->  Attempting to fetch iso-codes_3.43.orig.tar.xz from
> When I run with –dtv I see a 404 error code for each attempt, but I’m able to install other packages without problems, so it’s not a firewall issue.  And when I browse to one of these mirrors, I do not see a 3.43 version available, so the 404’s make perfect sense.
> Also, when I run info on iso-codes, it shows the older vesion:
> $ port info iso-codes
> iso-codes @3.43 (devel)
> Description:          This package aims to provide the list of the country and
>                       language (and currency) names in one place, rather than
>                       repeated in many programs.
> Homepage:   
> Extract Dependencies: xz
> Build Dependencies:   gettext
> Platforms:            darwin
> License:              LGPL-2.1+
> Maintainers:          l2g at, openmaintainer at
> What am I doing wrong here?  Or is this something that I need to report to the maintainers of iso-codes?  


sudo port selfupdate

to update your local portfile definitions to the latest version. As you can see here, the current version in MacPorts is 3.67:

I don't know how you ended up with an ancient portfile for iso-codes 3.43 on your system if you're new to MacPorts. 
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the macports-users mailing list