lilypond configure failure

Lenore Horner LenoreHorner at
Wed Aug 10 18:42:20 PDT 2016

I’ve just done a clean install of El Capitan.  I installed the texlive stuff I wanted and then tried to go on to install Lilypond.  That fails.  Just before failure,  a window pops up saying something needs to access x11 and I can either cancel or continue.  I tried cancel.  I tried installing xorg-server and then cleaning Lilypond and installing it again and got the same message.  This time I tried continue.  Lilypond failed again.  Oddly, the log seems to me to be saying that the problem is that fontforge isn’t installed but that did get installed as a dependency and is active (in fact isn’t that what the () in that line is admitting?). 

:info:configure ERROR: Please install required programs:  /opt/local/bin/fontforge >= 20110222 (installed: 2016-08-10 21:14:00.539 osascript[47227:131873)
:info:configure See INSTALL.txt for more information on how to build LilyPond
:info:configure Command failed:  cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_textproc_lilypond/lilypond/work/lilypond-2.18.2" && ./configure --prefix=/opt/local --with-ncsb-dir=/opt/local/share/fonts/urw-fonts --enable-documentation 
:info:configure Exit code: 1
:error:configure Failed to configure lilypond, consult /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_textproc_lilypond/lilypond/work/lilypond-2.18.2/config.log
:error:configure org.macports.configure for port lilypond returned: configure failure: command execution failed
:debug:configure Error code: NONE
:debug:configure Backtrace: configure failure: command execution failed
    while executing
"portconfigure::configure_main org.macports.configure"
    ("eval" body line 1)
    invoked from within
"eval $procedure $targetname"
:info:configure Warning: targets not executed for lilypond: org.macports.activate org.macports.configure org.macports.destroot org.macports.install

This is on a MacBook Air.  I have tried quitting Terminal and repeating the clean and install steps to no avail.  I have also started both X11.  Having X11 running when I tried to install Lilypond got rid of the pop-up.  I then tried opening FontForge by hand.  That tells me I need X11 installed. I have to start X11 by hand and then I can run FontForge.  However, having both running, still doesn’t let Lilypond install.  

What do I need to do so Fontforge can find X11 and start it?

What do I need to do so that Lilypond fully realizes that Fontforge is installed?

I don’t see a bug report that looks related.  Is anyone else having problems?  
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the macports-users mailing list