selfupdate error

Tai Viinikka tai at
Fri Feb 3 18:10:19 UTC 2017

I too was stuck at 2.3.5 with "no configure script found in vendor/tcl/unix"

On Thu, Feb 2, 2017 at 12:07 PM, Rainer Müller <raimue at> wrote:

> On 2017-02-02 17:40, pof at wrote:
> >  I suspect this is almost certainly due
> > to an issue with my own setup since I have seen no other similar
> > problems posted in the archives
> This has been reported before and unfortunately it is an upgrade path we
> did not expect or test. rsync does not preserve these symlinks.

Paul, thanks for mentioning this.
Rainer, I have a similar problem. Can you identify a bug opened in trac on
this upgrade/symlink issue?

Perhaps a key phrase (but Google is unhelpful):

>     configure: error: no configure script found in vendor/tcl/unix

Regarding your suggestion:

Edit your /opt/local/etc/macports.conf

Assuming you meant /opt/local/etc/macports/macports.conf, mine says:

> #rsync_dir              release/tarballs/base.tar

I uncommented the line so I could mess around with this setting and it
looks like this value might be wrong for some users.

Based on
only the US and UK still use that directory structure, and for everyone not
using those mirrors, we'd need:

rsync_dir                     macports/release/tarballs/base.tar

or similar.

I have tried to pursue this route, changing rsync_ and rsync_dir to match
several mirrors, and it has not fixed the vendor/tcl/unix problem.

Any suggestions welcome, including "Open a ticket" or "Add to ticket X."

I have looked at ticket #53414; the problem description is identical but I
have tried the solution offered, commenting out the relevant settings to
use defaults, and this does not change anything for me.

tai viinikka

tai at   ::::   East Pole Productions
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the macports-users mailing list