pan - start with at the new Pan 0.141

FritzS - gmx fritzs at
Fri Jan 6 09:16:44 UTC 2017

> Am 06.01.2017 um 08:12 schrieb Ryan Schmidt <ryandesign at>:
>> On Jan 5, 2017, at 07:26, FritzS - gmx <fritzs at> wrote:
>> Till today I start pan with a  script saved as
>> do shell script "/opt/local/bin/pan“
>> this worked well till the update to Pan 0.141 coming out now.
>> Now it comes the error report:
>> sh: gpg2: command not found
>> error "sh: gpg2: command not found" number 1011
>> gpg2 is located:
>> /opt/local/bin/gpg2  (macports)
> I guess pan now needs gpg2, and assumes it will be located in the PATH. The PATH you have set in your terminal includes /opt/local/bin, but the PATH that AppleScript runs "do shell script" with does not.
>> and
>> /usr/local/bin/gpg   - is a link to
>> /usr/local/MacGPG2/bin/gpg2 (from MacGPG)
> Having things installed in /usr/local can cause problems for software you install with MacPorts; I recommend you remove what you've installed in /usr/local.
>> At the moment I open pan with an double click to pan binary and this open a shell:
>> $ /opt/local/bin/pan ; exit;
>> What could I do that the my would work.
> Add /opt/local/bin to the PATH AppleScript uses:
> do shell script "export PATH=\"/opt/local/bin:$PATH\" && pan“

No I done this:

I uninstalled and reinstalled GPG_Suite

Installed them without

For apps which searched gpg or pgp2 hardcoded in /usr/local/bin/
I add symlinks from the macports path
sudo ln -s /opt/local/bin/gpg2 /usr/local/bin/gpg2  
sudo ln -s /opt/local/bin/gpg2 /usr/local/bin/gpg  

My script
do shell script "export PATH=\"/opt/local/bin:$PATH\" && pan"
do shell script "/opt/local/bin/pan“
works now (without set the path in script it does’t run too)
Pan 0.141 runs now well - but if I closed pan another error message comes again:
sh: gpg2: command not found
sh: gpg2: command not found (1011)

My path and other settings:
$ echo "$PATH"

$ export $LANGUAGE
declare -x DISPLAY="/private/tmp/"
declare -x GPG_AGENT_INFO="/private/tmp/"
declare -x LANG="de_AT.UTF-8"
declare -x PATH="/opt/local/bin:/opt/local/sbin:/usr/local/bin:/usr/bin:/bin:/usr/sbin:/sbin:/opt/X11/bin"
declare -x SHELL="/bin/bash“

More information about the macports-users mailing list