Now fixed: Re: Terminal problems after ports update

William H. Magill magill at
Sun May 14 23:23:27 UTC 2017

> On May 14, 2017, at 5:57 PM, Dave Horsfall <dave at> wrote:
> Well well...  After this morning's "port upgrade outdated" ritual, I see 
> that the ncurses library was updated.  Suspicious, I tried "rogue" (which 
> I recalled was failing as well, in hindsight) and it worked, and so did 
> Gnuplot!  Therefor it was a bug in the ncurses library introduced after 
> some other modification.
> I was baffled because VI was working (which doesn't use curses), so I 
> guess Gnuplot uses it indirectly via "readline" or something.
> Perhaps "rogue" should be included as part of the ncurses test suite :-)  
> It was written for it, after all, and believe me it gets hammered.
> -- 
> Dave Horsfall DTM (VK2KFU)  "Those who don't understand security will suffer."

Oh dear!!! I haven’t thought about Rogue for man years.

However, it appears that the install of Rogue still fails.
I just ran:

> sudo port selfupdate
--->  Updating MacPorts base sources using rsync
MacPorts base version 2.4.1 installed,
MacPorts base version 2.4.1 downloaded.
--->  Updating the ports tree
--->  MacPorts base is already the latest version

The ports tree has been updated. To upgrade your installed ports, you should run
  port upgrade outdated
You haven't run 'sudo port reclaim' in two weeks. It's recommended you run this regularly to reclaim disk space. Would you like to run it now? [Y/n]: Y
--->  Checking for inactive ports
Found no inactive ports.
--->  Building list of distfiles still in use
--->  Searching for unused distfiles                     
No unused files found.
[/Users/magill] magill 
 > sudo port upgrade outdated
--->  Fetching archive for ncurses
 . . . 
All updated as expected, so I decided to try to install Rogue for the first time.

> sudo port install rogue
--->  Computing dependencies for rogue
--->  Fetching archive for rogue
--->  Attempting to fetch rogue-5.4.4_3.darwin_16.x86_64.tbz2 from
--->  Attempting to fetch rogue-5.4.4_3.darwin_16.x86_64.tbz2 from
--->  Attempting to fetch rogue-5.4.4_3.darwin_16.x86_64.tbz2 from
--->  Fetching distfiles for rogue
--->  Attempting to fetch rogue5.4.4-src.tar.gz from
--->  Verifying checksums for rogue
--->  Extracting rogue
--->  Configuring rogue
--->  Building rogue
Error: Failed to build rogue: command execution failed
Error: See /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_games_rogue/rogue/main.log for details.
Error: Follow to report a bug.
Error: Processing of port rogue failed

:info:build mdport.c:264:17: error: incomplete definition of type 'struct term'
:info:build     if (cur_term->type.Strings == NULL)
:info:build         ~~~~~~~~^
:info:build /opt/local/include/term.h:710:16: note: forward declaration of 'struct term'
:info:build typedef struct term TERMINAL;

Sierra 10.12.4
Xcode 8.3.2 
Ticket #54171
Will have to play around to attach the log file — the Trac oprtion does NOT see /opt

William H. Magill

# iMac11,3 Core i7 [2.93GHz - 8 GB 1067MHz] OS X 10.12
# Macmini6,1 Intel Core i5 [2.5 Ghz - 4GB 1600MHz] OS X 10.12

magill at
magill at
whmagill at

More information about the macports-users mailing list