Macports installation problem

Ryan Schmidt ryandesign at
Wed Oct 18 14:50:07 UTC 2017

On Oct 18, 2017, at 04:25, John wrote:

>    I tried to install Cairo graphics 
>    and I need to install Macports. 

Welcome! Technically you don't *need* to install MacPorts if all you want is Cairo. You could build it and it's dependencies from source. But using MacPorts is indeed an easy way to get the job done. 

>    I tried to install Macports on my Mac OS Sierra 10.12.6, and type "sudo port install cairo", but it did not respond. I haven't seen any file name or app called Macports, but one file called "port" which is located at
> loca/bin/port"
>    How should I do it? 
>    Thanks,
> John
> *******
> Last login: Sun Oct 15 02:52:49 on console
> Johns-MacBook-Pro:~ john$ /opt/local/bin/port ; exit;
> MacPorts 2.4.2
> Entering shell mode... ("help" for help, "quit" to quit)
> [Users/john] > sudo port install cairo
> Error: Unrecognized action "port sudo"

You are correct; there is no GUI app called MacPorts. MacPorts is the command line program /opt/local/bin/port. 

The installer should have set up your PATH so that you can run it by just typing "port" instead of that full path. 

From your output above, I see you inadvertently entered MacPorts shell mode, indicated by the ">" prompt, by running "port" with no arguments. As it says, to exit that mode, type "quit" to get back to your normal shell's "$" prompt. At your normal shell "$" prompt, you can run "sudo port install cairo". 
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the macports-users mailing list