Apache 2.4.28 update today? (was:Re: Apache 2.4 any time soon?)

Bill Christensen billc_lists at greenbuilder.com
Thu Oct 19 19:55:56 UTC 2017


I originally ran the update to Apache 2.4, then quickly changed the active
Apache version back to 2.2 as I had not yet tested everything out.

I'm still running php70, and I found that mod_php70.so had been moved to
the new modules directory (/opt/local/lib/apache2/modules/).  Everything
worked fine when I moved it back to the original modules directory (

Now, a couple days later and having run some other updates (libcomerr and
php70_apache2handler). I once again found mod_php70.so in the new directory
and not in the old.  This time I made a copy, so it's in both places.

When I run configtest now, I see:

Cannot load /opt/local/apache2/modules/mod_php70.so into server:
dlopen(/opt/local/apache2/modules/mod_php70.so, 10): Symbol not found:
_ap_unixd_config\n  Referenced from:
/opt/local/apache2/modules/mod_php70.so\n  Expected in:
/opt/local/apache2/bin/httpd\n in /opt/local/apache2/modules/mod_php70.so

Pointers as to what to do next?


On Mon, Oct 16, 2017 at 10:48 AM, Marius Schamschula <lists at schamschula.com>

> Done in https://github.com/macports/macports-ports/commit/
> 1e70102f38315d1bfaa0d08401b3c41daf7e2dd7
> Also there are useful transition notes under https://trac.macports.
> org/ticket/50965#comment:18
> Well, the old apache2 installed everything under ${prefix}/apache2, which
> violated the MacPorts tree. The new version installs things under:
> 1) configuration - ${prefix}/etc/apache2/
> 2) data - ${prefix}/www/
> 3) binaries -   ${prefix}/sbin
> 4) modules -  ${prefix}/lib/apache2/modules
> I had meant add a note to the Portfile. I will add this.
> Marius
> --
> Marius Schamschula
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.macports.org/pipermail/macports-users/attachments/20171019/421d413c/attachment.html>

More information about the macports-users mailing list