Murray Eisenberg murrayeisenberg at
Sat Apr 7 18:50:13 UTC 2018

What’s happening now is befuddling to me. Doing the step 

   echo rsync:// >> /opt/local/etc/macports/sources.conf

as root (sudo su - ) seems to have worked, as /opt/local/etc/macports/sources.conf now ends with:

   rsync:// [default]

However, continuing as root, doing the step  

    port selfupdate


    Error: Synchronization of the local ports tree failed doing rsync

Could there be some issue with MacPorts access to the openmodelica repository?

Using rsync is completely new to me, and I don’t even know how to find out whether a particular source exists.

> On 7 Apr2018, at 1:17 PM, Ryan Schmidt <ryandesign at> wrote:
> On Apr 7, 2018, at 11:27, Murray Eisenberg wrote:
>> Thanks, that seems to have worked.
>> To do the remaining steps…
>> port selfupdate
>> port install gcc44 # With the addition of llvm/clang as the default compiler in XCode, many ports now fail to build unless you force GCC to be used
>> port install openmodelica-devel +libraries +clang 
>> …should I still stay in that root shell?
> It does say in their instructions, before those commands, "run (as root):"
> You will need to be root to selfupdate and install ports, but usually you should do that by putting "sudo" in front of those commands.
> It's unfortunate they're suggesting you should install an obsolete port like gcc44. The last version of gcc44 was released 6 years ago and we don't support it on High Sierra and later. The current stable version of gcc is gcc7.

Murray Eisenberg			murrayeisenberg at
503 King Farm Blvd #101	Home (240)-246-7240
Rockville, MD 20850-6667	Mobile (413)-427-5334

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the macports-users mailing list