Jupyter 2 and Jupyter 3

pagani laurent laurent.pagani at laposte.net
Thu Apr 19 17:12:27 UTC 2018

After totally cleaning my macports installation and reinstalling everything, I ended up having py27-jupyter and py36-jupyter installed :

Macports>port -v installed py36-jupyter
The following ports are currently installed:
  py36-jupyter @1.0.0_1 (active) platform='darwin 16' archs='noarch' date='2018-04-19T17:14:49+0200'
Macports>port -v installed py27-jupyter
The following ports are currently installed:
  py27-jupyter @1.0.0_1 (active) platform='darwin 16' archs='noarch' date='2018-04-19T11:58:23+0200’

but to activate the 2.7 version I can type :

jupyter notebook

while for activating the 3.6 version I finally found that I have to type the old style command :

ipython3 notebook

Why can’t I activate a jupyter3 version ? I tried this command :

sudo port select --set jupyter3 py36-jupyter
Selecting 'py36-jupyter' for 'jupyter3' failed: The specified group 'jupyter3' does not exist.

without success (ok, it was not offered but I tried…).


More information about the macports-users mailing list