Poppler and Snow Leopard

Riccardo Mottola riccardo.mottola at libero.it
Fri Dec 7 14:31:38 UTC 2018

Hi all,

today I tried to upgrade packages on SL 10.6, first I got this issue:

--->  Attempting to fetch poppler-0.71.0.tar.xz from 
--->  Verifying checksums for poppler
--->  Extracting poppler
--->  Applying patches to poppler
--->  Configuring poppler
Error: poppler cannot be built while another version of poppler is active.
Error: Please forcibly deactivate the existing copy of poppler, e.g. by 
Error:     sudo port -f deactivate poppler
Error: Then try again.
Error: Failed to configure poppler: poppler is active
Error: See 
for details.

So, I followed the de-activation suggestion,  then tried "upgrade" 
again, but of course it was not outdated, so I issued explicitely the 
upgrade of poppler which fails:

error: thread-local storage is not supported for the current target
   static thread_local std::default_random_engine 
1 error generated.
make[2]: *** [CMakeFiles/poppler.dir/goo/grandom.cc.o] Error 1
make[2]: *** Waiting for unfinished jobs....
make[2]: Leaving directory `/opt/local/var/macpo

I think this is related to the bug


right? But what can I do now? Currenlty I have clang5 and gcc6.5
  I suppose the same hammer will slash also 10.7 and even more 10.5.


More information about the macports-users mailing list