Poppler and Snow Leopard

Ken Cunningham ken.cunningham.webuse at gmail.com
Fri Dec 7 15:41:20 UTC 2018

If poppler now requires thread_local, that is a significant change.

If you're using libstdc++, you can try building with gcc6 or gcc7. 

Luckily, I believe my TLS-enabling  modificatins for clang and libcxx for 10.6 and earlier are ptetty much ready for use. Passes all the llvm test suite test that it should pass.


> On Dec 7, 2018, at 06:31, Riccardo Mottola via macports-users <macports-users at lists.macports.org> wrote:
> Hi all,
> today I tried to upgrade packages on SL 10.6, first I got this issue:
> --->  Attempting to fetch poppler-0.71.0.tar.xz from http://nue.de.distfiles.macports.org/poppler
> --->  Verifying checksums for poppler
> --->  Extracting poppler
> --->  Applying patches to poppler
> --->  Configuring poppler
> Error: poppler cannot be built while another version of poppler is active.
> Error: Please forcibly deactivate the existing copy of poppler, e.g. by running:
> Error:
> Error:     sudo port -f deactivate poppler
> Error:
> Error: Then try again.
> Error: Failed to configure poppler: poppler is active
> Error: See /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_graphics_poppler/poppler/main.log for details.
> So, I followed the de-activation suggestion,  then tried "upgrade" again, but of course it was not outdated, so I issued explicitely the upgrade of poppler which fails:
> /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_graphics_poppler/poppler/work/poppler-0.71.0/goo/grandom.cc:21:10: error: thread-local storage is not supported for the current target
>  static thread_local std::default_random_engine engine{std::random_device{}()};
>         ^
> 1 error generated.
> make[2]: *** [CMakeFiles/poppler.dir/goo/grandom.cc.o] Error 1
> make[2]: *** Waiting for unfinished jobs....
> make[2]: Leaving directory `/opt/local/var/macpo
> I think this is related to the bug
> https://github.com/macports/macports-ports/commit/0e637acf748bb168387fecb7cd9f4ebf92220957
> right? But what can I do now? Currenlty I have clang5 and gcc6.5
> I suppose the same hammer will slash also 10.7 and even more 10.5.
> Riccardo

More information about the macports-users mailing list