gcc49 fails to build

Christopher Jones jonesc at hep.phy.cam.ac.uk
Tue Jun 5 17:34:34 UTC 2018

> On 5 Jun 2018, at 5:42 pm, Dave Horsfall <dave at horsfall.org> wrote:
> On Mon, 4 Jun 2018, Ryan Schmidt wrote:
>> Here is the bug report corresponding to that problem:
>> https://trac.macports.org/ticket/56511
> Ooh - a utility called "sw_vers"!  I wonder what other hidden gems are lurking, essentially undocumented, on one of Apple's finest products?
> After over 40 years of Unix programming, this Mac never ceases to astonish me...  No, I'm not being sarcastic (for once).
> Anyway...
>> gcc4x is not compatible with Xcode 9.2. It may not be compatible with any Xcode 9.x. Use gcc5 or later if possible. We don't plan to backport the fixes to make gcc4x compatible with newer Xcode.
> And, err, how do I achieve that?  I have this odd expectation that MacPorts "just works" i.e. the dependencies have been taken care of for me.

What port are you installing/updating that requires gcc49 ? I.e. in your first message what was printed prior to

--->  Building gcc49
Error: Failed to build gcc49: command execution failed


Its possible you have a port installed using a gcc49 variant, and when you update this choice is maintained, even if the default has switched to a newer gcc. In these cases you need to manually remove the port and reinstall it with the newer defaults. What does

 > port installed | grep gcc

give you ?


> Speaking of Xcode, I keep being offered to upgrade it, but it will only run on High Sierra.  The first time I tried that, I got a message about something being incompatible with this box which I couldn't write down fast enough before it reverted to Sierra.  The next time I tried (paying more attention this time), it bombed out because a critical file was missing...  I suppose I'd better start putting money aside from my old age pension (yes, I'm a pensioner) to buy an Air or something.
> -- Dave, the iconoclast

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.macports.org/pipermail/macports-users/attachments/20180605/09871f09/attachment.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: smime.p7s
Type: application/pkcs7-signature
Size: 1910 bytes
Desc: not available
URL: <http://lists.macports.org/pipermail/macports-users/attachments/20180605/09871f09/attachment.bin>

More information about the macports-users mailing list