Odd mpv configure series failure following fresh reinstall

Lee Bast x-lists at asgarda.com
Thu Jun 7 21:57:25 UTC 2018

I did a selfupdate of a working 10.13 install running 2.4.4 to 2.5.0 and experienced failures so I rolled back, then tried again after 2.5.2 and experienced a different failure (ffmpeg wouldn't build). So I gave up and decided to blow the entire install away again and just buckle down and spend the hour to reinstall the exact same set of ports & variants. This time I got all the way through to the last one, mpv, and that choked, as generally seems to be the case with a configure failure:
> --->  Configuring mpv
> Error: Failed to configure mpv: configure failure: command execution failed
> Error: See /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_multimedia_mpv/mpv/main.log for details.
> Error: Follow https://guide.macports.org/#project.tickets to report a bug.
> Error: Processing of port mpv failed

Log of attempt #1 attached.

Looking at it, I saw it crapped out on checking lua, even though lua52 was supposed to be dealt with during the port install. So I tried manually running 'port install lua52' first, then giving it another spin. No dice, it still failed in config, except this time the lua check passed but it died on dvdread support, however it definitely reported fetching/installing/activating/cleaning libdvdread with no issues before it got to mpv, as would be expected. Log #2 also attached.

So I'm definitely confused here about what could be causing this, it seems like somehow the automatic install of reqs is not being noticed by config or activated in time or something? Is there any special fragility on systems I could look for, or something odd with Xcode/CLI tools recently or such? On both 10.12 and 10.13 systems I've had a lot of breakage during MacPorts upgrades in the last month. I've tried to reduce it by at least giving up on LibreSSL entirely, while it's what Apple uses and is more secure it's endless problems in MacPorts since it's not default like other systems. So at this point I don't think I'm doing anything too wacky. No changes whatsoever to any MP defaults, just a download of the latest version, selfupdate, and then ports.

I'm not sure what to investigate here to file a useful bug report, any suggestions would be much appreciated! Most of my systems don't have ZFS so recovery from upgrade fails can be more of a slog, if there's something I'm doing wrong I could fix and reduce complete reinstalls to 3-4 times a year or so I'd be happy to do so.

Thanks for any ideas in advance,

-------------- next part --------------
A non-text attachment was scrubbed...
Name: mpv install attempt 1 - main.log.tar.gz
Type: application/x-gzip
Size: 12409 bytes
Desc: not available
URL: <http://lists.macports.org/pipermail/macports-users/attachments/20180607/15dfee2b/attachment.bin>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: mpv install attempt 2 - main.log.tar.gz
Type: application/x-gzip
Size: 12435 bytes
Desc: not available
URL: <http://lists.macports.org/pipermail/macports-users/attachments/20180607/15dfee2b/attachment-0001.bin>

More information about the macports-users mailing list