gcc49 fails to build

Dave Horsfall dave at horsfall.org
Mon Jun 11 04:05:30 UTC 2018

On Thu, 7 Jun 2018, Ryan Schmidt wrote:

>> Speaking of Xcode, I keep being offered to upgrade it, but it will only 
>> run on High Sierra.
> I assume this upgrade offer is coming from the Mac App Store. I'm not 
> sure why it would offer you a version of Xcode that's not compatible 
> with your OS. It's supposed to know when something requires a newer OS, 
> and only display it as an "incompatible update" which cannot be 
> installed. That's what happens for me on Sierra.

Yep, the App Store, and no, I don't why either, but it does say 
"incompatible update" now (it didn't used to).

>> The first time I tried that, I got a message about something being 
>> incompatible with this box which I couldn't write down fast enough 
>> before it reverted to Sierra.  The next time I tried (paying more 
>> attention this time), it bombed out because a critical file was 
>> missing...
> I can't really diagnose the problem based on that description. Upgrading 
> to High Sierra will not fix the gcc49 build failure, but if you'd like 
> to upgrade to High Sierra anyway and are having trouble, please let us 
> know your exact computer model, and the specific error messages you're 
> encountering.

Sanitised version attached; it's a bit out of date, but the hardware has 
not changed.

I'll attempt another High Sierra upgrade later, when I have a few hours to 
spare, and report back.

-- Dave
-------------- next part --------------
{\fonttbl\f0\fswiss\fcharset0 Helvetica;}
{\*\listtable{\list\listtemplateid1\listhybrid{\listlevel\levelnfc23\levelnfcn23\leveljc0\leveljcn0\levelfollow0\levelstartat1\levelspace360\levelindent0{\*\levelmarker \{disc\}}{\leveltext\leveltemplateid1\'01\uc0\u8226 ;}{\levelnumbers;}\fi-360\li720\lin720 }{\listname ;}\listid1}}
{\author Dave Horsfall}}\paperw11900\paperh16840\margl1440\margr1440\vieww12800\viewh13400\viewkind1

\f0\fs24 \cf0 \ul \ulc0 Dave Horsfall\'92s MacBook\
\cf0 \ulnone \
Purchased around 13th March 2010.\
Model MC207xx/A, 13\'94 screen, serial number 45008Q7xxxx, late 2009.  The firmware calls itself a MacBook 6,1 (note the ",").\
4GB PC3-8500 1067MHz SO-DIMM DDR3 memory (dealer installed).\
2.26GHz dual-core 64-bit CPU.\
Nvidia GeForce 9400M 256MB.\
250GB SATA disk, now external USB due to damaged m/board connector.  Hitachi 5K500 B-250 2.5\'94 (9.5mm).\
DVD burner HL-DT-DVDRW GS23N.\
Battery 661-5391 (replaced).\
Was 10.6.8 Snow Leopard, various upgrades through Mavericks and Yosemite, now on Sierra 10.12.4 11/4/17 through to Sierra 10.12.6 plus sec. fixes (doesn't seem to like High Sierra).\
Was Xcode 5.1.1 plus command line tools, upgraded through to 8.3.1 12/4/17, now on 8.3.2 26/4/17; now somewhere around 9.2 14/12/17.\
Safari and Chrome not used; started with Firefox 33.0 instead, always upgraded through to 52.0.2 ??/4/17, 52.0.2ESR on 28/4/17, 53.0.3 24/5/17; zillions since since then, and now latest Quantum 59.0.2 28/3/18.\
MacPorts 2.3.2, now 2.4.1 ??/4/17; 2.4.2 on 9/10/17.\
Time Capsule 7.6.4, wireless on for testing remote access, Ethernet on.  Purchased 16th March 2010.\
Known current faults:\
\ls1\ilvl0\cf0 {\listtext	\'95	}No audio device found.\
{\listtext	\'95	}DVD won\'92t eject disk, and won\'92t read what\'92s in there.  Since removed, and found to be jammed and damaged.\

More information about the macports-users mailing list