port reclaim failing

Fielding, Eric J (329A) eric.j.fielding at jpl.nasa.gov
Mon Jun 11 14:39:56 UTC 2018

I ran a “port selfupdate” a week or two ago, so I am on 2.5.2. Today I tried to run “port reclaim” and it failed with an error about a missing table entry.

sudo port selfupdate
--->  Updating MacPorts base sources using rsync
MacPorts base version 2.5.2 installed,
MacPorts base version 2.5.2 downloaded.
--->  Updating the ports tree
--->  MacPorts base is already the latest version

The ports tree has been updated. To upgrade your installed ports, you should run
  port upgrade outdated
You haven't run 'sudo port reclaim' in two weeks. It's recommended you run this regularly to reclaim disk space. Would you like to run it now? [Y/n]: Y
--->  Checking for unnecessary unrequested ports
Error: reclaim failed: can't read "isrequested(adwaita-icon-theme)": no such element in array

Does this mean my MacPorts installation is corrupted somehow? I have never seen an error like this.


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.macports.org/pipermail/macports-users/attachments/20180611/8e852413/attachment.html>

More information about the macports-users mailing list