Official Gnucash and macports conflicting libgio-2.0.0.dylib

Ryan Schmidt ryandesign at
Sat Jun 30 15:08:46 UTC 2018

On Jun 30, 2018, at 09:28, nb wrote:

> I have macports 2.5.2 already installed.
> I have then installed Gnucash 3.2 dmg from
> When I run gnucash, I have the error:
> objc[93365]: Class GNotificationCenterDelegate is implemented in both /Applications/ (0x10c333670) and /opt/local/lib/libgio-2.0.0.dylib (0x117a41620). One of the two will be used. Which one is undefined.
> Segmentation fault: 11
> /opt/local/lib/libgio-2.0.0.dylib belongs to glib2 macports package.
> If I rename /opt/local/lib/libgio-2.0.0.dylib, gnucash works fine. But this can't be a solution.
> I've also tried to set DYLB_LIBRARY_PATH to
> /Applications/
> But this way I have the error
> Segmentation fault: 11
> Is there a way to run gnucash while macports installed ?

It seems wrong that a supposedly standalone installation of gnucash would have any knowledge of things installed by MacPorts in /opt/local. Why does it do that?

I downloaded it and I don't see any occurrence of /opt/local in it. I opened the app from the dmg and I didn't see the problem you saw.

Could it be a setting on your system that's causing this? Might you be setting DYLD_LIBRARY_PATH in /etc/launchd.conf? If so, try not doing that.

More information about the macports-users mailing list