problems with MP version of gfortran

pagani laurent laurent.pagani at
Sat Nov 10 15:34:35 UTC 2018


I am running OSX10.12.

I had gcc 7.3 and gcc 5.5.0_1 installed.

When trying to compile a simple .f90 code (simpling printing some double precision complex, a ”hello world” for complex numbers),
I get this error message :

SIGMA>which gfortran
SIGMA>gfortran -o essai essai.f90
FATAL:/opt/local/bin/../libexec/as/x86_64/as: I don't understand 'm' flag!

Then I selected the gcc5 version and the FATAL error disappeared. 
I selfupdated MP which moved from 2.5.3 to 2.5.4, and I upgraded outdated.

gcc7.3 still shows the error and gcc5.5.0_3 which was installed in the upgrade started to show the same FATAL error !
I tried to return to gcc5.5.0_1 but failed (probably did not do the right thing…)

I installed gfortran directly in /usr/local/bin, the version 8.1, and I have no FATAL error! I have not yet tried to install gcc8 via Macport but googling a little, people with the same problem seem to end up removing macport (/opt/local/bin) from their PATH, which is a bit extreme…

Is the problem known and solvable more cleanly ? I’d rather have a single gfortran on my laptop.


"S'il n'y a pas de solution, c'est qu'il n'y a pas de problème" (devise Shadok)

More information about the macports-users mailing list