problems with MP version of gfortran

Christopher Jones jonesc at
Sat Nov 10 19:09:18 UTC 2018


cctools was updated recently, changing the default variants it was built with. This caused issues with the gcc compilers, so those where rev-bumped last week to adapt.

The issue though is users on 10.2+  who had cctools installed would have done so with the xcode variant installed. The recent update that was pushed change this, and users need to make sure they update their installation to get this as by default, port will retain the previously requested variants a port was installed with, so would retain the now non-default Xcode variant. 

So you need to force reinstall cctools.

> sudo port uninstall cctools

ignore the warnings, then

> sudo port install cctools

you should then have the new defaults.

Unfortunately, the author of the recent cctools change did not put in code to automatic upgrade users from the xcode variant to the llvm70 variant (which is now the default). This should have been done. <>

When the Xcode variant was added a while back (to fix issues with the old cctools on Xcode 9 systems) code was added to automatically migrate users to it, see the removed line 64-75 above. Similar should have now have been added to put them back on the llvm70 variant.

cheers Chris

> On 10 Nov 2018, at 3:34 pm, pagani laurent via macports-users <macports-users at> wrote:
> Hi,
> I am running OSX10.12.
> I had gcc 7.3 and gcc 5.5.0_1 installed.
> When trying to compile a simple .f90 code (simpling printing some double precision complex, a ”hello world” for complex numbers),
> I get this error message :
> SIGMA>which gfortran
> /opt/local/bin/gfortran
> SIGMA>gfortran -o essai essai.f90
> FATAL:/opt/local/bin/../libexec/as/x86_64/as: I don't understand 'm' flag!
> Then I selected the gcc5 version and the FATAL error disappeared. 
> I selfupdated MP which moved from 2.5.3 to 2.5.4, and I upgraded outdated.
> gcc7.3 still shows the error and gcc5.5.0_3 which was installed in the upgrade started to show the same FATAL error !
> I tried to return to gcc5.5.0_1 but failed (probably did not do the right thing…)
> I installed gfortran directly in /usr/local/bin, the version 8.1, and I have no FATAL error! I have not yet tried to install gcc8 via Macport but googling a little, people with the same problem seem to end up removing macport (/opt/local/bin) from their PATH, which is a bit extreme…
> Is the problem known and solvable more cleanly ? I’d rather have a single gfortran on my laptop.
> Thanks,
> Laurent
> "S'il n'y a pas de solution, c'est qu'il n'y a pas de problème" (devise Shadok)

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: smime.p7s
Type: application/pkcs7-signature
Size: 1930 bytes
Desc: not available
URL: <>

More information about the macports-users mailing list