MacPorts and Mojave

Achille Fiore achillefiore at
Tue Nov 13 08:56:22 UTC 2018

Hello. I think that I have a problem with the update to Mojave. I was
installing via Macports an ESO pipeline following this procedure "Quick
start" described in .
This pipeline works just if a particular version of Java JDK (namely the
1.8) is installed, differently from mine that was the up-to-date one.Since
I did not notice that before, after I realised it had problems and which
was the underlying issue (the wrong Java JDK version), I had to uninstall
the pipeline: but actually if I run:

>sudo port list installed

I still see the eso-pipelines there. I tried to update with sudo port
selfupdate and then, as prompted,

>port upgrade outdated

at the Terminal prompts:

>Error: cfitsio cannot be installed for the configured universal_archs
'x86_64 i386' because it >only supports the arch(s) ''.
>Error: Follow to report a bug.

Could it be possibly an issue related to the new update Mojave? It seems
that Macports does not recognize anymore my architecture.

Thanks, Achille
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the macports-users mailing list