MacPorts and Mojave

Ryan Schmidt ryandesign at
Wed Nov 14 06:36:51 UTC 2018

On Nov 13, 2018, at 02:56, Achille Fiore wrote:

> Hello. I think that I have a problem with the update to Mojave. I was installing via Macports an ESO pipeline following this procedure "Quick start" described in . This pipeline works just if a particular version of Java JDK (namely the 1.8) is installed, differently from mine that was the up-to-date one.Since I did not notice that before, after I realised it had problems and which was the underlying issue (the wrong Java JDK version), I had to uninstall the pipeline: but actually if I run:
> >sudo port list installed
> I still see the eso-pipelines there.

Then I guess it's still installed, and if you want to uninstall it, you should do so.

However, note that "port list" does not do what you think it does. See:

> I tried to update with sudo port selfupdate and then, as prompted,
> >port upgrade outdated
> at the Terminal prompts:
> >Error: cfitsio cannot be installed for the configured universal_archs 'x86_64 i386' because it >only supports the arch(s) ''.
> >
> >Error: Follow to report a bug.
> Could it be possibly an issue related to the new update Mojave? It seems that Macports does not recognize anymore my architecture. 

The error message needs to be improved. What the error message really means is: You have asked for a port (cfitsio) to be installed with the universal variant (meaning: for both 32-bit and 64-bit), and 32-bit building is not supported on Mojave or later; don't use the universal variant anymore. If you have any ports installed with the universal variant, reinstall them without that variant.

More information about the macports-users mailing list