Installation of Macports appears to be corrupted.

Anand Pathak Sharma anand at
Sat Sep 29 02:10:31 UTC 2018

Hi everyone!

I cannot figure out what and how happened to cause this issue but today, 
out of the perceived blue, I found that my local nginx/mysql servers 
installed via macports have stopped working. I have a feeling this may 
be related to the user/group ownership of the files in question.

I tried uninstalling Nginx then re-installing it and received the 
following error:

    /Error: Unable to execute port: Could not open file:

On a whim, I tried doing the same for another port and received the same 

    /Error: Unable to execute port: Could not open file:

I moved into the directory, 
and checked the ownership of the files in it and they are set to:


When viewing the ownership of macport files in parent directories, I see 
that they are set to:


This inconsistency makes me feel that somehow ownership has changed and 
caused these issues.

I'd greatly appreciate some assistance with working out this matter.

Many thanks!

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the macports-users mailing list