ffmpeg Fails After MacPorts Migration to Catalina Version

Michael Newman mgnewman at mac.com
Fri Dec 13 23:28:39 UTC 2019

I’ve been using ffmpeg daily for several years to generate time lapse videos from a series of JPEGs.

After I updated my 2017 iMac to Catalina, it still worked.

However, after migrating MacPorts to the Catalina version, it fails:

./skyvideo.sh: line 38:  5438 Done                    cat $ipath
      5439 Segmentation fault: 11  | /opt/local/bin/ffmpeg -f image2pipe -framerate 10 -vcodec mjpeg -i - -vcodec libx264 -preset veryslow -hide_banner -loglevel panic -r 10 -crf 28 -y -pix_fmt yuv420p "$vfile" >> "$log"

Version information:

MrMuscle:bin mnewman$ port -v
MacPorts 2.6.2
MrMuscle:bin mnewman$ ffmpeg -version
ffmpeg version 4.2.1 Copyright (c) 2000-2019 the FFmpeg developers

The MacOS Problem Report is here:

https://pastebin.com/G6cN0t7Y <https://pastebin.com/G6cN0t7Y>

I had saved a pre-migration version of ffmpeg that I know worked, but it now fails in the same way.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.macports.org/pipermail/macports-users/attachments/20191214/ff7d2068/attachment.html>

More information about the macports-users mailing list