Issues after migrating dovecot from High Sierra Server to Mojave + MacPorts (solved)

Gerben Wierda gerben.wierda at
Mon Dec 30 15:18:44 UTC 2019

Just reporting in case someone else runs into this.

I’ve just migrated from an old dovecot server to a new one based on MacPorts dovecot etc..

The mailboxes have been migrated with doveadm backup and sync. Receiving and sending mail in the INBOX worked. Moving a message to another mailbox at the top level worked as well. Just not when there is a mailbox hierarchy and I’m more than one level down.

When trying to move a message from INBOX to another mailbox with Apple Mail (macOS Mojave) I got the following error:

	The IMAP command “UID COPY”  failed for the mailbox “INBOX” with server error: Character not allowed in mailbox name: '.'

dovecot showed no errors in mail-error.log or mail-info.log

Creating a Mailbox TestLevelOne worked and .TestLevelOne was created in the Maildir store
Creating a Mailbox TestLevelOne/TestLevelTwo didn’t work
Accessing any mailbox at level 2 did not work (only showed old cache)

mail-debug.og didn’t show anything when I tried this.

The solution was that somehow Apple (Mojave) had become corrupted. Removing its contents from ~/Library and recreating the accounts solved the issue.

Gerben Wierda
Chess and the Art of Enterprise Architecture <>
Mastering ArchiMate <>
Architecture for Real Enterprises <> at InfoWorld
On Slippery Ice <> at EAPJ

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the macports-users mailing list