Issues after migrating dovecot from High Sierra Server to Mojave + MacPorts (solved)

Gerben Wierda gerben.wierda at
Mon Dec 30 18:09:42 UTC 2019

Repairing my own message below.

The origin of the problem was that my High Sierra Server dovecot (always upgraded/migrated from the earliest MacOS X Server almost 20 years ago) used ‘.’ as the inbox namespace separator and the MacPorts one uses ‘/‘

When a new account is created on macOS, finds out what it is and uses that. worked fine with new accounts, but when I switched over from the old server to the new with existing accounts on macOS clients, they encountered a namespace problem.

So, to be backwards compatible with older macOS Server (easy migration) it is best to use the ‘.’ as inbox namespace separator for the MacPorts port. That way, existing clients can just be switched over without having to recreate all the accounts.


> On 30 Dec 2019, at 16:18, Gerben Wierda <gerben.wierda at> wrote:
> Just reporting in case someone else runs into this.
> I’ve just migrated from an old dovecot server to a new one based on MacPorts dovecot etc..
> The mailboxes have been migrated with doveadm backup and sync. Receiving and sending mail in the INBOX worked. Moving a message to another mailbox at the top level worked as well. Just not when there is a mailbox hierarchy and I’m more than one level down.
> When trying to move a message from INBOX to another mailbox with Apple Mail (macOS Mojave) I got the following error:
> 	The IMAP command “UID COPY”  failed for the mailbox “INBOX” with server error: Character not allowed in mailbox name: '.'
> dovecot showed no errors in mail-error.log or mail-info.log
> Creating a Mailbox TestLevelOne worked and .TestLevelOne was created in the Maildir store
> Creating a Mailbox TestLevelOne/TestLevelTwo didn’t work
> Accessing any mailbox at level 2 did not work (only showed old cache)
> mail-debug.og didn’t show anything when I tried this.
> The solution was that somehow Apple (Mojave) had become corrupted. Removing its contents from ~/Library and recreating the accounts solved the issue.
> Gerben Wierda
> Chess and the Art of Enterprise Architecture <>
> Mastering ArchiMate <>
> Architecture for Real Enterprises <> at InfoWorld
> On Slippery Ice <> at EAPJ

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the macports-users mailing list