gnupg problem "no pinentry"

Peter Hancock hancock at
Sun Feb 17 20:10:20 UTC 2019

On 17/02/2019 17:04, Carlo Tambuatco wrote:
> I’ve had this problem…noticed it when using gnupg in conjunction with org-decrypt on emacs org mode. 
> Also had to reboot whenever this problem cropped up…
> I’ve been using gnupg for almost 2 years now…I assume it is a known issue. I guess it still has not been 
> addressed.

I ran into a similar problem with Thunderbird a few days ago. It seemed to go away when I put the line:

     pinentry-program /Applications/MacPorts/

into my  .gnupg/gpg-agent.conf 

Or perhaps it was that I set up this situation in /opt/local/bin: 

lrwxr-xr-x  1 root admin    15 Mar  5  2018 /opt/local/bin/pinentry.old -> pinentry-curses
-rwxr-xr-x+ 1 root admin 65440 Mar  5  2018 /opt/local/bin/pinentry-curses
lrwxr-xr-x  1 root wheel    67 Feb 14 07:27 /opt/local/bin/pinentry -> /Applications/MacPorts/

It was reading a link to something in the Thunderbird web-site (that popped up when I tried to send a signed message)
that led me to do these things. Sorry, I can't remember much more than this.

More information about the macports-users mailing list