after latest update, gimp not opening files

Riccardo Mottola riccardo.mottola at
Sat Jun 1 21:09:06 UTC 2019

Hi Lenore,

On 2019-05-31 22:48:45 +0200 Lenore Horner <LenoreHorner at> wrote:

>> May 31 22:22:34 Kaiserin [0x0-0x1d01d].org.gimp.GIMP[28473]: 	Using the 
>> fallback 'C' locale.
>> May 31 22:22:35 Kaiserin [0x0-0x1d01d].org.gimp.GIMP[28473]: Session D-Bus 
>> not running. Try running `launchctl load -w 
>> /Library/LaunchAgents/org.freedesktop.dbus-session.plist’.
> This looks like the problem to me because it’s a common failure

I tried that and see thast retrying tellms me it is already loaded:

Kaiserin:~ multix$ launchctl load -w /Library/LaunchAgents/org.freedesktop.dbus-session.plist 
Kaiserin:~ multix$ launchctl load -w /Library/LaunchAgents/org.freedesktop.dbus-session.plist 
org.freedesktop.dbus-session: Already loaded

I still get a failure in GIMP opening a file, but the messages are limit to this:

6/1/19 11:06:29.973 PM [0x0-0x90090].org.gimp.GIMP: (file-jpeg:96750): Gtk-WARNING **: 23:06:29.972: Locale not supported by C library.
6/1/19 11:06:29.973 PM [0x0-0x90090].org.gimp.GIMP: 	Using the fallback 'C' locale.
6/1/19 11:06:30.096 PM [0x0-0x90090].org.gimp.GIMP: terminate called throwing an exception/Applications/MacPorts/ fatal error: Abort trap: 6
6/1/19 11:06:30.105 PM [0x0-0x90090].org.gimp.GIMP: /Applications/MacPorts/ LibGimpBase-WARNING: GIMP: gimp_wire_read(): error

any further clues?


More information about the macports-users mailing list