XCode 11 on Mojave problem, again

Henning Hraban Ramm hraban at fiee.net
Sat Nov 9 16:35:41 UTC 2019

> Am 2019-11-09 um 15:07 schrieb Chris Jones <jonesc at hep.phy.cam.ac.uk>:
>> On 9 Nov 2019, at 1:50 pm, Henning Hraban Ramm <hraban at fiee.net> wrote:
>> Hi,
>> I also had problems on Mojave, since at least cctools was expecting a MacOSX10.14.sdk in /Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs; on Mojave there’s only the 10.15 SDK.
>> I had XCode 10.something and updated yesterday to 11.latest; that needed some hours...
>> Since I didn’t find a way to install a 10.14 SDK, I just made a symlink to the 10.15 SDK under the name of MacOSX10.14.sdk, and it works so far!
> That is a bad idea, pretending a 10.15 SDK is a 10.14 one could lead to unforeseen side effects. So this is not something we recommend anyone does.

I’m a cowboy coder ;)

> Have you tried installing the CLT ? That should provide a 10.14 SDK that the latest MacPorts release will use. 

I thought CLT was installed with XCode. I tried now and it didn’t change the SDKs.


More information about the macports-users mailing list