Failed to install libgcc9: no destroot found

Vahid Askarpour vh261281 at
Fri Sep 27 10:42:18 UTC 2019

I followed the steps you outlined with no problem. Here is the terminal output:

VahidAskarpour:~> sudo port uninstall libgcc
VahidAskarpour:~> sudo port selfupdate
--->  Updating MacPorts base sources using rsync
MacPorts base version 2.6.0 installed,
MacPorts base version 2.6.0 downloaded.
--->  Updating the ports tree
--->  MacPorts base is already the latest version

The ports tree has been updated. To upgrade your installed ports, you should run
  port upgrade outdated
VahidAskarpour:~> sudo port sync
--->  Updating the ports tree
VahidAskarpour:~> sudo port upgrade outdated
Nothing to upgrade.
--->  Scanning binaries for linking errors
--->  No broken files found.
--->  No broken ports found.

However, when I tried to install xcrysden, I got the same error. Here is the terminal output:

VahidAskarpour:~> sudo port install xcrysden
--->  Computing dependencies for xcrysden
The following dependencies will be installed:
Continue? [Y/n]: y
--->  Installing libgcc9 @9.2.0_0
Error: Failed to install libgcc9: no destroot found at: /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_lang_gcc9/libgcc9/work/destroot
Error: See /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_lang_gcc9/libgcc9/main.log for details.
Error: Follow to report a bug.
Error: Processing of port xcrysden failed

I have attached the log file which is similar to the one I posted yesterday.


On Sep 26, 2019, at 9:49 PM, Chris Jones <jonesc at<mailto:jonesc at>> wrote:

sudo port upgrade outdated

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: main.log
Type: application/octet-stream
Size: 80737 bytes
Desc: main.log
URL: <>

More information about the macports-users mailing list