Why are my por definitions still out of date after this?

Gerben Wierda gerben.wierda at rna.nl
Sat Feb 22 11:43:50 UTC 2020

I have my own fork of the macports-ports repository on GitHub so I can do maintenance. I have a local clone of that fork

When I want to update ports I do not maintain, do the following. First I make sure my clone is up to date with the upstream original, then I push the clone back to my GitHub fork. Then I run portindex. ‘upstream’ is the official repo, origin is my fork
git fetch upstream
git checkout master
git reset --hard upstream/master
git push origin master --force
But when I do that, I still get:

albus:macports-ports sysbh$ port list updated
Warning: port definitions are more than two weeks old, consider updating them by running 'port selfupdate'.

(Should have said ‘outdated’ of course, this doesn’t give me a warning)

But port self update overwrites everything using rsync and doesn’t go via git. So, it is a parallel and possibly trouble-creating route. I want update my local tree entirely via git.

Still, with a clean clone of of an up-to-date fork, I can do it:

sudo port selfupdate
--->  Updating MacPorts base sources using rsync
MacPorts base version 2.6.2 installed,
MacPorts base version 2.6.2 downloaded.
--->  Updating the ports tree
--->  MacPorts base is already the latest version

What is the way to go when updating, using your own clone of your own fork of the git repo?

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.macports.org/pipermail/macports-users/attachments/20200222/b57963f9/attachment.html>

More information about the macports-users mailing list