ports directory (from git fork&clone) up to date, still a warning

Ryan Schmidt ryandesign at macports.org
Tue Jan 28 17:31:29 UTC 2020

On Jan 28, 2020, at 10:20, Gerben Wierda wrote:

> When I work with a cone from my own macports-ports fork, port commands complain about
> Warning: port definitions are more than two weeks old, consider updating them by running 'port selfupdate'.
> Even if I have just reset my fork to the current state of the official repo, I still get this.

This message refers to the portindex file; MacPorts doesn't check anything else. So after you update or reset your fork to the current state, run "sudo portindex" in it. Or run "sudo port sync" which should do that for you after updating your git clone.

> But if I run ’self update’ my setup gets overwritten with rsync from the official port (I think). I have the feeling I am mixing two ways of updating in an unholy mix.

"sudo port sync" (and "sudo port selfupdate", which runs "sudo port sync" internally) don't overwrite your setup. They synchronize whichever ports collections you've configured in sources.conf, be they rsync-based, git-based, svn-based, http-file-based, or whatever.

The one thing that "sudo port sync" does overwrite is any changes you might have made in an rsync- or http-file-based source. But it will not affect any changes you've made in a source that comes from a revision control system like git or svn.

More information about the macports-users mailing list